March 25th, 2004, 14:37
Previously, I had trouble with my FreeBSD install on an Inspiron 8100 (1ghz P3, 512 meg RAM, 32 meg nVidia GeForce2Go with nVidia drivers installed) locking a sound on a continual loop of static noise when I would play an mp3 and type at the same time. Stopping typing did not stop the lock, the only way to stop the noise was turn down the mixer, kill XMMS, and wait a while. I solved that problem by switching the output from OSS to esound. Still being relatively new to *NIX as a desktop OS, I have no idea on Earth why this solved the problem, but it did. Since then, I have upgraded most of the ports involved and now it doesn't matter whether I use esound or OSS. Neither freeze, but both are affected by the problem described below:

I've noticed that when I play videos or MP3s, every four or five seconds, there is a momentary skip in the audio. This occurs in XMMS playing mp3s and mplayer playing videos of all formats (ogm, xvid avi, divx, mpeg).

On an unrelated note, I also seem to be unable to hear audio in downloaded Quicktime files. I can see the video, but no sound.

Any suggestions will be greatly appreciated. Thanks guys!

March 25th, 2004, 22:50
Umm I've had this problem, back when I used Red Hat, and you probably want to up your audio buffers under xmms(Options->Configure->Buffering). As for mplayer you'll want to let it drop some frames run `mplayer --help' or press 'd' when you're running a video, off the top of my head I can tell you how to buffer stuff on mplayer but run 'man mplayer' and you'll find some stuff to speed things up on slower machines.

There's more stuff you can do but that should get you on the right path.

Good luck.

March 25th, 2004, 23:36
Thanks for the suggestion, I'll check into that, especially for an older P2 I want to turn into a home media center. What ended up immediately helping the majority of my problem was closing the power monitoring utility I was using, xbattbar. With it gone and the KDE sound system turned off, things seem to be much more in keeping with a 1ghz machine.

Even still, if I issue the 'apm' command to check battery status it will balk for a second during playback. I'm not sure why this happens, but I'm willing to live with it.

Thanks again!